0 votes

After updating to a newer version I can't save or update anymore as both give error on file copy. I'm on version 3.2.35.1759 and I also tried manually downloading the latest version, but it has the same problems.

Saving fails when it tries to copy the project file to a .bak file and updating fails when it tries to copy platforms/libqxcb.so to a backup folder. Both give out same error message (only with different file paths):

*** Unhandled Atomix exception
*** Qt information:
Error <boost::exception> sending event 11QMouseEvent to object  (11QToolButton)
*** Exception information:
axCore/axFileSystem/helpers/fileHelper.cpp(131): Throw in function static bool Atomix::CFileHelper::CopyFile(axPath, axPath)
Dynamic exception type: boost::wrapexcept<Atomix::CException>
std::exception::what: std::exception
exception_message: Can't copy file [/path/to/MyProject.skipper] to [/path/to/MyProject.skipper.bak]. Error: boost::filesystem::copy_file: Invalid argument: "/path/to/MyProject.skipper", "/path/to/MyProject.skipper.bak"

File permissions are not the issue, old version of Skipper worked fine with same files. Also, it does create the file it is trying to copy to, only it's left empty.

After Googling for the error message, found some discussion in another programs github issues about boost being "quite fragile, sensitive to quirks of platform dependence and various file systems" and there were talk about it not working on encrypted filesystem. I am on Linux and I have encrypted home folder, so I tried saving the project file outside my home directory and then it works without errors. Never had any problems with any other software regarding the encrypted home directory and I have been using it for many years, and even the old version of Skipper was working just fine. Hope you can fix this quickly, currently can't really use it at all as I can't save any changes.

in Solved by (320 points)
recategorized by

Hello Carl,
thanks for the report. You're the first one who reports this.

Can you please send me the link with the discussion about problems with boost and encrypted file systems?

We can try to check whether the boost library has some fix for this issue and hope they already fixed that. But it's strange that no one else has this issue.

And one more question, what version of Linux are you using, please?

Can you also try the latest beta from here: https://www.skipper18.com/support/402/downloads-skipper-beta ?

Here's the discussion about boost: https://github.com/prusa3d/PrusaSlicer/issues/6588

I'm on Pop!_OS 21.04 which is based on Ubuntu 21.04 (kernel version 5.15.8-76051508-generic) and my home partition is using ecryptfs

Tried the new beta version, but it has the same problem.

1 Answer

+1 vote
Best answer

Hello Carl,
I just deployed the new Skipper beta with upgraded libraries to the latest versions including a boost upgrade to 1.78

https://www.skipper18.com/support/402/downloads-skipper-beta

This version should contain a fix for your issue. Please test it and let me know.

Thanks

by Skipper developer (139k points)
selected by

Tested and it's working now!
Thanks.